News

Java Security Update Required

Due to recent security exploits, faculty and staff accessing the campus network with personal or self-managed computers should update Java to either version 1.6.0_31 or 17.0_03.Read More